electric fencing problem

_daisy_

Well-Known Member
Joined
17 March 2005
Messages
5,619
Location
South Yorkshire
is anyone good with mains energisers?

we set up the mains energiser the weekend before last and it was working great till sometime today. It was ticking away happily this morning when i left the yard (about 7am) Got there tonight and it was quiet, not ticking, no flashing no nothing. SO i checked the sockets to see if they had gone, checked the fuse box - nope not that. So then I checked the fuse in the energiser plug - still nothing.

Problem is, although this unit is a brand new Mustang 10, I bought it off ebay approx 4 years ago for our previous yard but the the owner never got main electric on. So its been sat in its box ever since - but now is out of the manufacturers 2yr warranty. I could try ringing them and explaining? do you think they might help? you can tell its had no wear/tear on it. its still all bright yellow, not even dust on it lol.

so could htere be something inside thats gone? maybe another fuse?
 

Toby_Zaphod

Well-Known Member
Joined
8 August 2005
Messages
8,899
Location
Midlands
I would phone the company & chat to their customer services. If nothing else they can let you know someone in your area that can take a look at it. Possibly one of their service agents?
 

_daisy_

Well-Known Member
Joined
17 March 2005
Messages
5,619
Location
South Yorkshire
cheers T_Z, ive managed to find the company on ebay from where i bought it from and have messaged them asking if they can help me. i really hope they can. im useless when it comes to electrical items, most things ill have a go at fixing but not this one.
I do have a agricultural merchant who seel energisers so they might send it back to the company for me if i get no luck from the ebayer.
 

Mike007

Well-Known Member
Joined
28 May 2009
Messages
8,222
These energisers have a stepdown transformer and rectifier then an energiser circuit . There is almost certainly an internal fuse on the low voltage circuit. Job for an expert I,m afraid. But probably easily fixable. Why it blew may take some investigation though.
 

_daisy_

Well-Known Member
Joined
17 March 2005
Messages
5,619
Location
South Yorkshire
thanks Mike - ill get it taken down this weekend and off to the agri merchants and see if they can send it to the manufacturer for me or advise me best of where to send it.
Saying that though my dad is very good so hell probably strip it down and have a go at it - he fix my battery energiser when it got vandalised.
 

_daisy_

Well-Known Member
Joined
17 March 2005
Messages
5,619
Location
South Yorkshire
B_O_F - theeres nothing going into the box, its not flashing or ticking which is making me think that theres something wrong. theres no pulse or anything going into the rope ive got up.
 
Top